Welcome to the AFK Mods bug tracker. In order to report an issue, please select a project from the drop down menu below. Select “Open New Issue” and fill out the form with as many details as possible.

An account will be required to submit an issue, so if you need one and are unable to register, please contact us via the forums at https://afkmods.iguanadons.net/
       

Issue Data
Status: Closed
Issue Type: Bug Report
Project: Unofficial Fallout 4 Patch
Component: Fallout 4: Vanilla
Category: Actors
Assigned To: Nobody
Platform: All
Severity: Low
Votes: 0
Watching: N/A
Opened By TantricSlacker on Nov 20, 2016 8:46 am
Last Edited By Arthmoor on Oct 18, 2017 4:18 pm
Closed By Arthmoor on Oct 18, 2017 4:18 pm
Resolution: Cannot Reproduce

Issue #21562: All properties of consumables are zero

Hi.

I realize this is may be outside of the scope of the good work you're doing, but as it is possibly a systemic issue with the base game (and how it saves games, at least on XB1), perhaps it is within your scope. The main two issues for this request:

1. Several weeks ago I noticed that my character stopped taking any rad damage anywhere for any reason. Standing in my underwear in one of the highly radioactive ponds in the Glowing Sea and I don't even hear the geiger counter tick effect. My character does have +50 rad resistance through perks, but I doubt that's high enough to shut down the usual feedback system that my character is in proximity of radiation.

2. I noticed that after taking some damage, stimpaks did not heal me and no healing food or drink helped either. After scanning down my "Aid" category in my inventory I noticed that all property/effect values for everything -- food, chems, drinks, etc. -- are zero. And any food or thing created/derived from a recipe has zero-valued properties.

I'm not sure what caused it, though I suspect it was in using a mod that was in heavy experimental development and changes.

Naturally the first thing I tried was disabling all mods, clearing cache, and loading up a save. Not resolved, still all zero.

So I loaded up both my oldest "modded" game (just after I installed Far Harbor when released) and a non-modded game. In both cases all consumables were as they should be, all properties filled.

I spent the better part of a day naively uninstalling and reinstalling everything. Of course, no solution.

This leads me to believe that there is an awful lot that persists in save gaves, even issues and defects.

I do have the creation kit and have been tinkering with it so I thought maybe I could create my own patch by brute forcing each to refresh/reset. I set stimpaks, corn, and buffout (the items under the ALCH form type) to +1 values so that they would be saved to my mod. I loaded the mod up (XB1), loaded up a save game, and no change. That was a surprise.

I'm not sure what to do at this point. I'm not savvy with scripting yet. I suspect there's probably some way to set/revert every consumable to its preset.

I suspect that whatever this issue is the rad thing is probably related in some way, e.g. environmental and object rad levels (something I can't see) have been set to zero.

If this falls outside of your scope I was hoping that at least you could provide me with some guidance on how to fix this myself. If there is a scripted way to do this maybe you could give me an example.

Obviously this seriously cuts down on my immersion level! :) I wonder if anybody else has had or is having this issue.

Much appreciated!