Welcome to the AFK Mods bug tracker. In order to report an issue, please select a project from the drop down menu below. Select “Open New Issue” and fill out the form with as many details as possible.

An account will be required to submit an issue, so if you need one and are unable to register, please contact us via the forums at https://afkmods.iguanadons.net/
       

Issue Data
Status: Closed
Issue Type: Bug Report
Project: Unofficial Fallout 4 Patch
Component: Fallout 4: Automatron DLC
Category: Actors
Assigned To: Nobody
Platform: Windows PC
Severity: Medium
Votes: 0
Watching: N/A
Opened By CrankyCat on Dec 31, 2017 8:27 am
Last Edited By Arthmoor on Jul 30, 2018 7:33 pm
Closed By Arthmoor on Jul 30, 2018 7:35 pm
Resolution: Can't Fix - Engine Issue

Issue #23423: Player created robot names revert to 'automatron'

I've seen this reported as a bug elsewhere after experiencing it. I can assign a name to an automatron when creating it but the name always reverts to 'automatron' afterwards. Because of this I always end up with all of my robots having the same name. It doesn't always happen immediately but I'm not sure what triggers it. For example I name a new robot "Provisioner 01" but it ends up being called "automatron" anyway. When upgrading at the robot workbench this is particularly annoying since they all say "Automatron" except for the vanilla NPCs.

I have read discussions of this happening globally after completing the Automatron main quest but for me it happened from the start.

Also, I'm not sure this is related, but when building a robot in the robot workbench if I don't rename it right away eventually trying to rename just renames the part I'm working on and not the robot itself.

I expected to see someone else reporting this here so perhaps it doesn't always happen? I have not started the "Reunions" quest.

My load order: https://pastebin.com/i6fnKrtx

Some other discussions:
https://www.reddit.com/r/fo4/comments/4bliz9/automatron_help_cant_rename_automatrons/
https://www.reddit.com/r/Fallout/comments/4e1e5q/spoilers_accessing_kelloggs_terminal_renames_my/ (Spoilers)
https://steamcommunity.com/app/377160/discussions/0/392184342869631277/

       
Related Issues: 23695  

Comments

1 comment(s) [Closed]
Arthmoor said:
This is likely related to the same bug that causes them to reset on provisioning routes and other issues. This doesn't appear to be something we can solve. It's an engine issue related to objects in settlements resetting when they're not supposed to.

       
Showing Comments 1 - 1 of 1